OSS上传插件安装配置后,默认还是使用的本地上传

楽猪 2月前 184

配置

上传头像

刚开始的时候试了一下免费的upyun插件发,发现配置后还是上传到本地。
然后我又买了下OSS插件,然后是“离线安装”的。发现配置完成后还是使用的本地。

我测试的是 控制台->常规管理->个人配置里的上传头像。

浏览器缓存清理了。然后最上方的菜单按钮“一键清除缓存”都清除了 还是不行。

fastadmin版本是1.0.0.20180911_beta

brand.kd.do 是我本地开发机手动配置的hosts
最后于 2月前 被楽猪编辑
最佳回复
  • 楽猪 2月前

    终于找到原因了。创建完项目后我把TP框架下,application目录下的config目录调整到了和application同级了。如下

    ├── LICENSE
    ├── README.md
    ├── addons
    │   └── alioss
    ├── application
    │   ├── admin
    │   ├── api
    │   ├── build.php
    │   ├── command.php
    │   ├── common
    │   ├── common.php
    │   ├── index
    │   ├── tags.php
    │   └── traits
    ├── bower.json
    ├── build.php
    ├── composer.json
    ├── composer.lock
    ├── config
    │   ├── config.php
    │   ├── database.php
    │   ├── extra
    │   └── route.php

    主要是把config.php database.php route.php以及extra目录做了调整。然后public/index.php文件加入了

    //定义配置文件目录和应用目录同级
    define('CONF_PATH', __DIR__.'/../config/');

    才导致了问题。但是目前依然不知道为什么真正的原因是什么。

    上周开始做上传的时候才发现装完插件依然还是使用本地上传。

最新回复 (2)
  • Karson 打赏 2月前
    感谢TA
    0 引用 2

    @楽猪 这种情况只有当你的addons.js未更新,才会这样,请检查下你的addons.js文件,如果有更新说明是你浏览器缓存问题。如果未更新说明你的文件权限无法写导致的,建议开发阶段给全部写权限。

  • 楽猪 楼主 最佳回复 2月前
    感谢TA
    0 引用 3

    终于找到原因了。创建完项目后我把TP框架下,application目录下的config目录调整到了和application同级了。如下

    ├── LICENSE
    ├── README.md
    ├── addons
    │   └── alioss
    ├── application
    │   ├── admin
    │   ├── api
    │   ├── build.php
    │   ├── command.php
    │   ├── common
    │   ├── common.php
    │   ├── index
    │   ├── tags.php
    │   └── traits
    ├── bower.json
    ├── build.php
    ├── composer.json
    ├── composer.lock
    ├── config
    │   ├── config.php
    │   ├── database.php
    │   ├── extra
    │   └── route.php

    主要是把config.php database.php route.php以及extra目录做了调整。然后public/index.php文件加入了

    //定义配置文件目录和应用目录同级
    define('CONF_PATH', __DIR__.'/../config/');

    才导致了问题。但是目前依然不知道为什么真正的原因是什么。

    上周开始做上传的时候才发现装完插件依然还是使用本地上传。

    最后于 2月前 被楽猪编辑
  • 未登录
    4
返回